Hello everyone, the day a lot of you fear is coming: I am going to retire all the OLD (only the old!) versions of my MD Vendor System. Here all you need to know:

  • Which products are going to be retired?
    • MD Buy/Buy As Gift Script (old name for MD Vendor System);
    • MD Vendor System;
    • All the available plugins for the versions of MD Vendor System that are going to be retired;
  • Which versions of the above products are going to be retired?
    • MD Buy/Buy as Gift Script version 1.7.2, released on 2014-05-21;
    • MD Buy/Buy as Gift Script version 2.1.0, released on 2014-12-12;
    • MD Buy/Buy as Gift Script version 2.2.x, released on 2015-02-06;
    • MD Vendor System version 3.0.0, released on 2015-11-30;
    • MD Vendor System version 3.0.1, released on 2015-12-07;
    • MD Vendor System version 3.0.2, released on 2016-02-01;
    • MD Vendor System Plugin – Remote Control version 1.0.x, released on 2015-11-30;
    • MD Vendor System Plugin – Store Credit & Gift Card version 1.0.x, released on 2015-11-30;
    • MD Vendor System version 3.1.0, released on 2016-05-17;
    • MD Vendor System version 3.1.1, released on 2016-05-21;
    • MD Vendor System Plugin – Remote Control version 1.1.x, released on 2016-05-17;
    • MD Vendor System Plugin – Store Credit & Gift Card version 1.1.x, released on 2016-05-17;
  • When this will happen? 
    • the old versions retirement will start on April 15th, 2019;
  • Why are you doing this?
    • the versions listed above are old: they still run on the old server and use ‘old’ code, which relies on obsolete technology. For this reason and in order to keep improving the quality of my work, I cannot afford anymore to maintain the back-compatibility with those versions using such an old technology.
  • What will happen from the retirement day?
    • all the vendors – new and existing – running one of the above versions will stop communicating with the server. This will have mostly three effects:
      • all the vendor’s feature relying on the server will stop working;
      • no data will be stored on the server anymore, so new vendors and new transactions will not be shown on MD Labs Online Services website;
      • it will be impossible to interact with the vendors through the MD Labs Online Services website;
  • What should I do to avoid all this?
    • Simple: update your vendors. For doing this you will need the updated version of the product ; you can receive the updated version simply clicking on the “update” button from one of your vendors (owner menu>update) or through the redelivery terminal at MD Labs in-world store. Once obtained the updated version, unpack it and inside there will be all the necessary scripts and info to perform the update.
  • Can the update be done automatically?
    • Yes, in some cases. Depending on the vendor system version you are currently updating from you will be able to use the auto updater that can be found in the update pack and called: [Auto Updater] MD Vendor System 4.0.x
    • Detailed instructions on how to perform the auto update can be found here;

IMPORTANT: I know this is going to be a lot of work for several of you as there are thousands of vendors running old versions of the scripts, but this is really necessary to me in order to be able to work on the next releases of my system being sure to have a consistent and reliable base.

Once the older versions will be retired I will NOT offer support anymore for those devices, so please update in time to avoid any issues.

Please contact me in-world if you need any help before the retirement day.

Banner Logo v4 256x64 edit 3